Soluzione (La codifica HTTP dei caratteri)

Area dedicata alle Guide
Regole del forum
Immagine
Rispondi
phpBB3World.org
Staff phpBB3World
Staff phpBB3World
Messaggi: 21
Iscritto il: 14 gen 2014, 21:57

Soluzione (La codifica HTTP dei caratteri)

Messaggio da phpBB3World.org » 23 apr 2016, 1:33

Attenzione La codifica HTTP dei caratteri in ingresso non è correttamente configurata

mbstring.http_input e mbstring.http_output deve essere impostata su pass. Puoi controllare il valore corrente nella pagina Informazioni *php. Attenzione
Cattura.PNG
Prima
Cattura2.PNG
Dopo

Avatar utente
maggino
Utente phpBB3World
Utente phpBB3World
Messaggi: 5
Iscritto il: 25 giu 2018, 12:51

Re: Soluzione (La codifica HTTP dei caratteri)

Messaggio da maggino » 25 giu 2018, 13:01

Buongiorno,
ho letto il link. Dice di aggiungere una stringa al file .htaccess.
In quale directory lo trovo?

Grazie
Mauro

Avatar utente
Rey
Staff phpBB3World
Staff phpBB3World
Messaggi: 602
Iscritto il: 3 nov 2012, 13:41
Località: 在世界上
Umore:
Contatta:

Re: Soluzione (La codifica HTTP dei caratteri)

Messaggio da Rey » 25 giu 2018, 18:32

lo trovi nella root del forum ovvero dove si trova anche il file config.php

Avatar utente
maggino
Utente phpBB3World
Utente phpBB3World
Messaggi: 5
Iscritto il: 25 giu 2018, 12:51

Re: Soluzione (La codifica HTTP dei caratteri)

Messaggio da maggino » 26 giu 2018, 16:44

Allora ho sbagliato qualcosa.

Nel file .htaccess ho questo codice:

AddHandler x-mapp-php6 .php

Dove incollo la stringa indicata?

php_value mbstring.http_input pass

Grazie
Mauro

Avatar utente
Rey
Staff phpBB3World
Staff phpBB3World
Messaggi: 602
Iscritto il: 3 nov 2012, 13:41
Località: 在世界上
Umore:
Contatta:

Re: Soluzione (La codifica HTTP dei caratteri)

Messaggio da Rey » 27 giu 2018, 11:25

lo incolli in uno spazio vuoto, infondo al file .htaccess

Avatar utente
maggino
Utente phpBB3World
Utente phpBB3World
Messaggi: 5
Iscritto il: 25 giu 2018, 12:51

Re: Soluzione (La codifica HTTP dei caratteri)

Messaggio da maggino » 4 lug 2018, 10:28

Dev'essere che sbaglio qualcosa.

Modifico il mio file .haccess che si trova nella root principale del forum che diventa così:


AddHandler x-mapp-php6 .php
php_value mbstring.http_input pass


A quel punto come pagine del forum mi compare questo errore:

Codice: Seleziona tutto

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Dove sbaglio?

Grazie
Mauro
Ultima modifica di Galandas il 6 lug 2018, 2:34, modificato 1 volta in totale.
Motivazione: Inserito errore nel tag codice

Avatar utente
Rey
Staff phpBB3World
Staff phpBB3World
Messaggi: 602
Iscritto il: 3 nov 2012, 13:41
Località: 在世界上
Umore:
Contatta:

Re: Soluzione (La codifica HTTP dei caratteri)

Messaggio da Rey » 6 lug 2018, 2:32

Infocomunque per essere chiaro qui non do supporto, ma qualche volta se sono della vena giusta lo do. cercherò per questa volta di fare un eccezzione.Meno
  1. Piu Postami nel BBcode codice il file .haccess fammi dare un occhiata.
  2. Piu la versione che usi di phpBB
  3. Piu la versioni php che usi sull'hosting che ti ospita
  4. Piu link al tuo forum per vedere il codice sorgente di persona.

Avatar utente
maggino
Utente phpBB3World
Utente phpBB3World
Messaggi: 5
Iscritto il: 25 giu 2018, 12:51

Re: Soluzione (La codifica HTTP dei caratteri)

Messaggio da maggino » 6 lug 2018, 11:42

Grazie sei gentile...

file .haccess:

Codice: Seleziona tutto

AddHandler x-mapp-php6  .php
Versione phpbb 3.0.12
Versione PHP 5.6

www.majestyclubweb.it/forum

Avatar utente
Rey
Staff phpBB3World
Staff phpBB3World
Messaggi: 602
Iscritto il: 3 nov 2012, 13:41
Località: 在世界上
Umore:
Contatta:

Re: Soluzione (La codifica HTTP dei caratteri)

Messaggio da Rey » 6 lug 2018, 15:17

Dai un occhiata in ACP in Log errori che potrebbe aiutare a determinare che cosa ha causato il problema.

C'è ovviamente qualcosa di specifico nella configurazione del tuo server che sta causando questo. Non posso dirti immediatamente di cosa si tratta, perché il messaggio di errore è molto generico.

Rispondi

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti